Back to overview
Degraded

Packiyo Support Help Desk Delays

Feb 28 at 05:09pm EST
Affected services
packiyo.com

Resolved
Feb 28 at 05:31pm EST

Intercom (our helpdesk) is now back to optimal performance - thank you for your patience!

Created
Feb 28 at 05:09pm EST

Our support desk is operated via Intercom and is currently experiencing degraded performance. Please note that this will delay support responses from the Packiyo Support Team.

Intercom status can be found here: https://www.intercomstatus.com